[CentOS]编译安装gcc-6.3.0

rt

gcc7.2.0太新有些软件支持不好

太旧也不行

个人感觉6.3.0比较好用

参考链接:http://www.junww.com/server/2017/0315/222.html


安装过程:


先安装依赖:

yum -y install libmpc-devel  #gmp-devel和mpfr-devel会同时装上

然后下载gcc-6.3.0

screen -S gcc #编译时间很久很久,可以开几把游戏放松一下

wget ftp://ftp.gnu.org/gnu/gcc/gcc-6.3.0/gcc-6.3.0.tar.gz
tar xvf gcc-6.3.0.tar.gz
cd gcc-6.3.0
mkdir build && cd build #编译出错时可以直接删除目录方便重来
../configure --prefix=/usr/local/gcc --enable-threads=posix --disable-checking --disable-multilib --enable-languages=c,c++,go --with-gmp=/usr/local/gmp --with-mpfr=/usr/local/mpfr --with-mpc=/usr/local/mpc

make  #巨久

make install

接下来备份原本的gcc

mv /usr/bin/gcc /usr/bin/gcc-bak
mv /usr/bin/g++ /usr/bin/g++-bak
mv /usr/bin/c++ /usr/bin/c++-bak

安装gcc-6.3.0

ln -s /usr/local/gcc/bin/gcc /usr/bin/gcc
ln -s /usr/local/gcc/bin/c++ /usr/bin/c++
ln -s /usr/local/gcc/bin/g++ /usr/bin/g++
ln -s /usr/local/gcc/lib64/libstdc++.so.6.0.22 /usr/lib64/libstdc++.so.6

检查一下

gcc --version



发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注